Hardware maintainance
Incident Report for OAPPS
Resolved
This incident has been resolved.
Posted Mar 21, 2023 - 11:51 GMT+04:00
Investigating
We are currently investigating this issue.
Posted Mar 21, 2023 - 11:28 GMT+04:00
This incident affected: Channels (Instagramer Direct for FreshDesk).