Instagram DMs issue

Incident Report for OAPPS

Postmortem

What has happened:
Instagram messages were queued and not properly delivered from Feb 21st, 12 PM UTC till the issue was fixed on Feb 23, 12 PM UTC.

Root cause
The issue was related to unexpected Instagram API changes to the followers_count and avatar image request responses. The patch to fix the issue was deployed on Feb 21, 2026, at 11 PM, and it also delivered queued messages if no account was disconnected.

Remediation steps

1. To improve server-side error rate reporting - elevated error rate reporting should alert in case of new error types and elevated error rates.

2. To add a low message deliverability alert specifically

3. To implement automatic 24x7 notification of urgent issues reported by customers.

Posted Feb 23, 2026 - 21:51 GMT+04:00

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 17:29 GMT+04:00

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 23, 2026 - 16:28 GMT+04:00

Identified

We have identified the issue and released the fix.
Posted Feb 23, 2026 - 16:17 GMT+04:00

Investigating

We are currently investigating this issue.
Posted Feb 23, 2026 - 16:02 GMT+04:00
This incident affected: Channels (Instagramer Suite for Zendesk, Intagramer Suite for FreshDesk).